I have the 1st Mic and now the app doen't open

Hi!

So if I have the version 1 of the mic, I have to get the new version of dubler?

Isn’t that a scam?

The old version of the app doesn’t work and now If I want to keep on using the mic, I have to buy the new app?

Is there any solution?

Hi Andres,

The mic is exactly the same for both version 1 and 2 of Dubler. There is no difference and it can be used with either one. Dubler 1 is still supported

It sounds like a separate issue with the Dubler app not opening. Are you getting crashes or any particular error message? Can you provide details of your setup