Software Problems / Unusable for my productions

Hi, was quite excited for Dubler and am just testing it. Unfortunately so far it has been a pretty disappointing experience and the software feels quite buggy.

I’m running Win10 Pro with Ableton 10.1. and have set up everything correctly - in general it works as expected

BUT:

  1. Every now and then (every 20-30 seconds) I get lingering notes where a “Note Off” doesn’t seem to get sent by Dubler. Have to manually do a Midi Reset in Ableton.

  2. Throughout the testing Dubler stopped working several times. Just out of nowhere. The Dubler software stills shows Mic input data but doesn’t send Midi to Ableton anymore. Have to restart Dubler.

  3. Not a real bug but the super sensible pitch sensitivity makes it difficult to use for me at the moment. I have decent skills singing correct pitch and still I get a small couple of super short passing notes at the start of every note. Also whenever I get too flat or sharp Dubler rapidly switches between the two adjacent notes which sounds like a trap hihat and definitely needs to be smoothed out.
    I understand that look-ahead is not possible so Dubler can not distinguish unwanted/short from wanted notes. But I tried changing “Input Sensitivity” and “Stickiness” and although there is a slight difference (not a big one though) it doesn’t really help with the issue. Maybe some kind of adjustable treshhold for note length would help here, so super short notes are filtered at the expense of a little latency.

Using Dubler right now means a lot of manual editing to remove those short notes and if sounds have a clear attack it’s just no fun using it due to constant audible mis-triggering.

If you want to re-create my problems, just put the basic Operator (sine) patch on a midi track in Ableton. I work in a quiet place using headphones without any background noise.

EDIT: Another thing: Just tried out the Midi CC and also it doesn’t make sense at all to be honest. Maybe i have the ‘wrong’ voice or am missing something setup-wise (have not seen any training for that)… but the CC control is super unreliable. I’d expect to sing “AAAA” and have the mapped controller respond according to the volume of my “Aaah” - Not happening. It just jumps around somewhere in the middle and does not react at all to volume. Even when I stop the value doesn’t go back to zero but stays in the middle or at max instead.
Obviously there must be something seriously wrong with my settings here.

Please let me know what I can do to get rid of those issues.
Thanks.

2 Likes

Glad to know I’m not the only one experiencing issues in Windows 10. I have a fast setup and a good interface (RME Babyface) but bought this as a plug and play with little extra cabling and ASIO4ALL useability - my other midi peripherals work fine like this. Even with the RME setup I still have similar issues. What follows is my latest email with tech support, who suggested installing a virtual midi router:

Hi Cam, the virtual midi device is not giving any improvement. There does appear to be less latency but it goes haywire after about 5 seconds recording and I have to restart all related drivers. This is with turning the virtual midi toggle to the left (so it is red) and selecting loopBE internal midi, then activating the Track and Remote button in Ableton midi section.

There is a visual delay with triggers as well.

I tweaked some ASIO4ALL settings and have achieved 1.45 ms latency (less than my Babyface which at its lowest buffer is 5.58 ms) as reported by Ableton, yet there is still noticeable latency from the Dubler mic only; approximately a 32nd note at 120 BPM (~64 ms) - nearly impossible to sing an actual drum groove against a metronome. I double checked the latency by plugging in my Arturia Keylab and there is no noticeable latency. It’s an issue with Dubler hardware/software, certainly.

Using the RME babyface, it was slightly improved but a noticeable lag was still present when triggering drum samples, the samples clearly sound after the appropriate noises are made with my mouth. Furthermore the triggers are very glitchy and it is very difficult to get a consistent pattern as the triggers get confused easily. I’ve recalibrated triggers with the recording button several times (using a minimal amount - kick, snare, closed hat), trying different singing volumes from loud to soft as well as adjusting input sensitivity in various directions. Any rhythm/groove beyond a basic 8th note pattern is completely impossible to capture with accuracy.

The melodic function is just as problematic and I couldn’t find any way to use it usefully.

Also, every time I open the Dubler app, it does not remember my audio device settings, which is very inconvenient. It crashed several times while I was trying out different drum/pitch settings and I would have to reroute it every time.

At current, I would say that the app and mic are less reliable than Ableton’s built in audio-to-midi feature, which was the reason I bought Dubler (as a faster/real time/more reliable version that what Ableton does). I will try the mic soon on my iMac setup, but I absolutely had the expectation that this product would work equally well across OS platforms.

Please advise with any assistance, thanks.

Hi

Thanks very much for bringing this to our attention. We’ll starting looking into points 1 & 2 and see if we can find these bugs when using with Windows 10. It sounds like an issue between the app and virtual MIDI but as mentioned we’ll have a look and try find the problem

We have a few extra things in place which should hopefully improve the pitch to MIDI experience, as you mentioned chromatic can often put out some flats or sharps when using the voice, so the most sure fire and easiest way to get rid of these is using the Key Lock feature. However we understand this isn’t always ideal, so there is also the note collector feature which allows you teach Dubler the notes you want to work with. Our help page here goes a bit more in depth with these: https://help.vochlea.co.uk/article/key-fixing-and-chords/

The MIDI CC dials don’t actually work on the volume of a certain vowel. The envelope dial labelled ENV actually deals with this, and you should see when increasing the volume that this dial goes up. The vowels are actually based on how ‘close’ or ‘true’ you are to that particular vowel, which allows you to blend and have wider timbral control over parameters. For example a pure AAA sound should have the dial all the way up but as you move over to an EEE you’ll see the dial go down as the EEE goes up allowing you to blend between the two. There’s a brief explanation in this video which I hope clears things up: https://www.youtube.com/watch?v=kHYjJXQ3akk&t=14s

As mentioned we’ll look into those possible bugs, but if there’s anything else you have questions on do let us know. Always happy to jump on a video call as well needed

All the best,

Liam

Hi Liam, thanks for your answer. Hope that the mentioned bugs get sorted out soon.

I tried the keylock feature and yes, it helps a bit, but some more control for smoothing would
definitely be necessary in my opinion.

Concerning CC control through vowels:
After watching the video I wonder even more what your initial concept for that feature is and if it at all was beta tested in any musical practical application (sorry, don’t want to be mean but I just don’t see how I could apply it to anything in my production workflow).
I mean, even in your video it clearly shows that the values do not go back to zero when their specific vowel is not performed anymore, they just stay somewhere (for example see their position at 0:36).
What am I supposed to do with that? Randomize synth parameters? There’s definitely no way to control delicate parameters (one of the reasons for my Dubler purchase) under these circumstances.

Please enlighten me what I’m missing and why the values do not return to zero.
Thanks

I also have problems with lingering notes, it is very annoying!

Regarding, aaa, eee, ooo, it seems these measure how much the microphone data passing through Dubler sound like prototypical human aaa, eee, ooo. If that is correct, then they don’t match in 100% with my voice, my pure aaa apparently sounds in 90% like prototypical aaa and 10% prototypical ooo. But that’s ok, when I change my mouth shape between aaa and ooo, the respective meters change in the correct directions. Eee quickly makes eee meter to 100% and ooo to 0%. To make these meters useful, I remap the MIDI ranges.

Recently I’ve discovered that they don’t work only for voice, just few minutes ago I’ve connected my guitar to Dubler, and was able to get useful musical data out of that, for example:

  • pitch + pitch bend mapped straight to the synth,
  • envelope mapped to reverb dry/wet,
  • ooo mapped (via CC#2) to filter cut-off frequency.

It was really cool sound, no other tool allows me such control :grin: Sadly, for now it only works for me with MSoundFactory, the reason being smoothing of midi data.

Hey berlincalling,

We did actually at one point have the dials go back to zero. It seemed like the natural way to implement it because it feels like you’re expressing a vowel and then you’re not.

But after testing, we actually found it was more functional from a music making perspective to leave the dials where they were, because it allowed a user to set a certain amount of a particular CC and leave it on.

Later on maybe we could switch to a different mode, to switch in to zero CC behaviour.

I’ve added it to the list, perhaps we can do some feature request polls to the community once we’ve gathered a significant amount, to ensure we get our priorities right :+1: :slightly_smiling_face:

Cheers!

I too am having some of these issues.

  • I’m getting a note 'stuck on ’ often. This is on Win 7 64, with Reaper, with synths from different manufacturers. It persists when changing patches or other parameters. The only thing that works to stop it, is to remove the VSTi from the track entirely.

  • I am also getting extra notes as has been reported elsewhere. This is with Stickiness all the way up, and Sensitivity anywhere, including all three way down. The idea of smoothing the Midi might be a useful solution.

Hey all,

Very sorry about the lingering MIDI problem reported by Windows users.

Please note this is a high priority on our TODO list.

Cheers,
-Daven

1 Like

Thanks Daven.

Let me know if you need more details.

If any Windows Cubase users have problems with latency, just remember to turn on “Constrain Delay Compensation”. I forgot that and suffered crazy latency as a result.

Thanks for the heads up on this. Will make sure to include in out Cubase setup page

hello… finally got the time to try this out.
I too am having problems with the pitching recognition.
I am getting a pitch of one tone down.

running windows 10 with focusrite saffire.
I have tried both 44 and 48khz.
makes no difference…

jon o

updated software… now only a semi tone out… and I do sing in tune. and my keyboard agrees with me .
thar reads a semitone out too. i used in kontakt 5 where i could compensate by transposing key but this shouldn’t be necessary.