Really struggling with latency

Hi I havre just bought Dubler and am really struggling. I use cubase 11 on a Mac with Mojave. iMac (Retina 5K, 27-inch, 2017). 3.4 GHz Intel Core i5 RAM 20 GB 2400 MHz DDR4. My audio interface is a steinberg UR 22. My problem is that the mic will not respond to any notes faster than a half note, with a delay of a couple of seconds between each note at least. I tried to follow the Cubase set up and reduced the latency to 128 but that makes no difference. I tried in built in audio which makes no difference and I also tried using it without cubase with individual vst intstruments and again that makes no difference even with reducing latency on them. I have tried the stickiness and the input levels and the key detection makes it even worse. I saw the videos with people singing really fast and the dubler responding so I really cannot understand what is going on. screenshot attached any help appreciated as I struggle with my hands and need something like this as I thought it would be the answer to my needs but my experience so far has been really very negative. Thank you.

ps I am plugging the mic straight into the computer

Did you try playing with the buffer size a bit more? Like either lowering it each selection… for example 128-32. Raising the buffer size will definitely make it worse but do it anyway to see what happens.

Another thing I had problems with at first was midi to instrument tracks. It works better on a instrument track at 1/8th note… you might got to play with the tempo and note metronome.

Another thing you can bus your midi track to a six track and channel it from there. I use pro tools 12.8.3 2017. My mac is 2011 iMac i5 21inch. 32gb ram

thanks for the response . I have tried the buffer sizes. I also tried it in garage band to see if it would make any difference but it only makes a slight difference. It is for me completely useless as a composing tool as I might as well play the keys because there is so much adjustment. . i was hoping I could sing a tune to help me with quick arrangements but this doesn’t appear to do that job. If I input a key then it will not change the note at all unless I sing in that exact key, which defeats the object.

Hi, I can see we’ve got a video call setup today so hopefully we’ll find the root of the latency problem. If we do resolve it I’ll post in here for anyone else following who may have experienced a similar issue in Cubase!

HI Liam thank you for all your help. I’ve juggled around quite lot with it and I think I am ok now. the difficulty I think it getting the right vocal level going in and the discipline of it. It is quite hard work but I think I’m getting there so now need for the call at the moment I think.
many thanks for everything and coming back so quickly

No worries, if you haven’t seen it already I’d recommend checking out our tips for pitch video here: https://www.youtube.com/watch?v=CQ4e4Oxh56A&t=1s&ab_channel=VochleaMusic

Whilst trying these tips I’d recommend leaving the stickiness and input level at around 75% which is the default setting, just to get used to how Dubler reacts before adjusting

But if you ever want a video chat just let me know!