Sample rate not recognised error when i open Dubler 2

Please help. Took the plunge and purchased Dubler 2. When i first installed it a week ago it was working like a dream. Now when i open it standalone or whilst the DAW is running i get a sample rate error. It won’t play any midi through a VST. Only inbuilt sounds it will work perfectly, this includes capturing and then dropping into a VST midi track. But i really want it for real time use utilising other VST’s.

I’m on Windows 10
FL Studio
Focusright Scarlett Solo interface

Steps i’ve taken:
I’ve uninstalled and reinstalled all drivers for Focusright
I’ve uninstalled and reinstalled both Dubler 2 and Midi capture
I’ve tried 3 other sample rates inside my FL Studio and Dubler matching
I’ve confirmed there are no conflicts with windows.
Virtual Midi option is “On”

FL Studio works perfectly. no error messages or sound issues.

Please help!


Hey all, further developments whilst i await and answer (Vochlea i’ve emailed your help email this morning).

I plugged in my Moog Grandmother this morning in FL Studio and it came up with an error for Dubler 2 in the midi window (Dubler 2 wasn’t open). This should leave further info so that it should be easy for you to let me know what to try.


Oh my. It’s fixed!

Microsoft MIDI Mapper had a button “Send master sync” on. No idea how or when that happened. Days and days lost trying to fix it all for button :(.

Spoke to soon. I opened FL and Dubler this morning and got the same sample rate message.

However, even after the message it now played through the VST’s which is improved. Annoying to get the sample rate warning upon bootup now.

This is my Scarlett Solo settings that i get to through the bottom right of windows.


Hi, does this error message only occur in FL Studio? Do you have any other DAW that you could test with?

Can you also try set the focusrite, Dubler and FL to a different sample rate such as 41000, to see if the same issue persists after this? It looks like a sample mismatch but it could also be a generic driver issue, so I would also recommend a fresh reinstall of the focsurite ASIO drivers from their website. Let me know how you get on

Hi Liam,

Thanks for the reply. No other DAW to test with today, but could defeinitely try this if need. I have reinstalled the ASIO Drivers already fresh, this doesn’t help.

I have changed to the only lower option 44,100 across Focusrite, FL and Dubler and the same message persists.

However, as per your email i think we’ve cracked the case wide open. You’re saying Dubler2 shouldn’t be in my Output on FL. Only Input.

This makes sense and i think this could be the problem. However, I can’t do anything to remove it from the Output list.

What i can do is upon opening is change the Port number of the Dulber 2 output to “Blank” and this disables it which seems to work. However, upon closing FL Studio and booting up again it’s enabled in Output again under Port 1 and the error message pops back up about the sample rate.

There is no option to delete it. And i even tried saving the settings under my custom template for bootup and restarted and this only results in FL Studio re-enabling it under Port 1 and it being active again as an output.

Surely there is a way to have it not be an output in FL? Let me know if you have ideas. I’m up for a video link too or i can do a quick Loom video and show what’s going on in real time if that helps.