Unusable Latency on Mac, Ableon Live 11 and Apogee Mic+ Interface

I just purchased Dubler2, set the microphone to my Apogee Mic+, calibrated, set my audio buffer to 32, and the latency is very, very bad. It’s completely unusable.

I’m an advanced user, and my setup runs like a finely tuned watch, so something is awry.

What now??

Please respond quickly, I just plopped $200 on this.

Macbook Pro i9, Mojave, Ableton 11.1.6, Apogee Mic+, Dubler 2

Could you first let us know what device you are using as your output? Is it in-built audio, or an external audio interface?

If you could send screenshots of Ableton’s audio preferences we can spot anything that could be adding latency. Alternatively if you’d like to arrange a video chat you can email us at help@vochlea.co.uk and we can take a look with screen sharing

I am using an apogee mic+. It has an output.

My setup is simple. I have the apogee mic+ set as the input and output in ableton, and a project with one track to test my setup: an operator synth, with dubler2 as the midi in. Audio in doubler is set to 32. I’ve tried 16, as well. The setup couldn’t be simpler. It is unusable, the latency is very very slow.

I have followed all instructions, calibrated, and set the buffer in dubler to as low as 16.it is unusable. the detection is extremely inaccurate, and the latency is unusable. the detection of cc11 using the envelope output is also extremely inaccurate and jumpy. i bought dubler to use with swam solo instruments, but the inaccuracy, latency makes it unmusical and basically useless.

please advise

1 Like

in your instructional video for singing melodies and key detection, you sing a melody that includes no half-steps. When singing a melody with half-steps, the pitch detection is at it’s worst, wobbling between triggering the adjacent notes, and creating an extremely unmusical experience. i have gone over the tutorials over and over again, and tried every setting possible for stickiness, etc.

This software is a nice idea, but it needs a ton of work.

I’m open to re-purchasing in the future if you can tighten the detection quite a bit, but at the moment I’d like to arrange a refund - I feel strongly that I’ve wasted $200 at this point

Sorry about that. It sounds like there could be some setup issues still that aren’t completely obvious. If you’d like we can arrange a video chat still just to double check? It’s hard to pinpoint exactly what is giving you bad response without hearing any examples or videos

I’d be confident on a call together we could find the root of the problem. I asked previously about audio output as USB mics outputs such as the Apogee are normally intended for low latency monitoring of the mic input and not feeding the audio of your DAW through. There’s a chance this could be causing audio feedback and causing mistriggers. (For example the output in Ableton is set to MiC Plus, which in turn is your input in Dubler, hence possible feedback and interference)

This may not be the solution, but it would be worth experimenting with a different output if possible such as in-built audio, or even different inputs as well. This would then pinpoint what was causing issues

Regardless you’re of course still entitled to a refund if you wish, and you can process this via your Vochlea account. It’s also worth mentioning that for the best results we recommend dynamic microphones, not condensers like the Apogee. Although it shouldn’t get terrible results as you’ve described, so I would guess the issue still lies elsewhere!

I don’t think feedback is the issue, as the output on the mic+ is a headphone output.
I’m happy to try to jump on a call, but i’m curious, do you have any examples of someone using a key including half-steps, like c-major, triggering accurately? Right now the pitch detection between half-steps is the worst part of the experience. It’s as if i have to be a trained classical singer to use it.
When can we have a call?

There are lots of videos on our Youtube, and many will contain uses with keys including half steps. At a quick glance there are a couple here -


But I’ll be more than happy to do some demonstrations on a video call. Like any new instrument there can be a slight learning curve, but making sure you’re singing clear and distinct notes can be a big help, especially when moving between two notes. So for example when singing with an ‘aaa aaa aaa’ sound, is common to glide up and down between notes. If you try a percussive sound at the beginning it can help make the note onset more obvious and separate it from previous notes, so like ‘daa daa daa.’ You can hear an example and explanation of this at this timestamp: https://youtu.be/zEKUkwgrYYg?t=51

Either way we can try first eliminate the setup issues discussed above. If you email us at help@vochlea.co.uk I’ll send you a link to book a slot for a support call

Yes, I’ve watched the videos and tried singing percussive sounds at the beginning of each not, etc. It doesn’t work well for writing complex melodies with alot of half-steps (not EDM)
I sent an email to link up on a call - it’s a last-ditch try that I’m open to, but this does seem more geared to EDM with extremely simple, mechanical melodies

Again, even in the video with the timestamp that you sent, there are no notes sung that are a half-step apart. You are singing a melody with wide intervals. Once half-steps are sung between, Dubler becomes jumpy and unusable. For complex scales with many half-steps, it really does seem to require a vocal accuracy that only a trained singer would possess -

Okay well let’s do the video chat and we can go through steps in person with some examples! I’ve sent a link via email

Very precise notes can be more difficult on condenser microphones due to the amount of pitch information they are picking up, hence we suggest dynamics. But with some adjustments we should hopefully be able to improve your experience

Excellent work, Folks. Had a call with Josh & we re-calibrated with a closer mic position. Seems to work much better.

Cheers

Having similar issues here with my ableton and Mac setup, dubler2 mic and using the builtin sound card or my Audient ID44.

The same amount of latency/ delay on the midi notes from Dubler VST, like a half step. Please advise whenever possible, thank you.

1 Like

Hi, If you haven’t done so already please contact us at help@vochlea.co.uk or also post screenshots in this thread of Ableton’s audio preferences, Dubler’s audio device settings and any other explanation of your setup. We can then try spot anything that might be causing this issue

Thank you, Liam. I have opened a ticket with help@vochlea.co.uk, but have not received a response for a few days now.

Screenshots attached.

Computer specs:
Screenshot 2023-04-19 at 9.20.55 AM

Ableton config:

Dubler2 config:

Ableton midi note latency:

The dubler2 mic is plugged directly into my macbook pro via the USB-C adapter that it came with. Latency is always around the same amount delay no matter what I do. Any help would be greatly appreciated, I would love to get this working correctly and address the latency issue.

Thank you!

Just an update, heard back from support with the possibility to refund everything, but I would like to troubleshoot this latency before processing the refund. Thank you.

Apologies for the slow reply on support. We’ve had slower response times recently due to NAMM show and travelling back to the UK. But we’ll definitely work to troubleshoot the latency first. It may also be easiest to arrange a video chat to take a look in person, but that can be arranged via your support ticket

Can you first confirm if the latency is consistent across both pitch and triggers, or only happens with one of these? Can you also send a screenshot of the Options menu in Ableton? There are some settings here which can effect input latency. The Options drop down is at the top of your screen alongside File, Edit e.t.c

No worries, thank you for getting back to me. The latency is just with the midi notes, always the same amount of time. Please see the screenshot below of options menu.

Thank you,